AMILO

Две разные CMS на одном домене

55 posts in this topic

@Indigo88, это точно... Вот не пойму почему оно забрасывает в циклическую переадресацию? 

Share this post


Link to post
Share on other sites

@AMILO, а где вы вставляете приведенные вам куски? Может слишком поздно и он не успевает сработать?

AMILO likes this

Share this post


Link to post
Share on other sites

@Indigo88, я уже по-разному пробовал... И спереди, и внутри, и в конце... Результата нет...  

Share this post


Link to post
Share on other sites

Сколько нужно комнатных оптимизаторов чтобы исправить роутинг? Эта тема тому пример.

Во вложенной директории (2ой скрипт) в .htaccess добавить (после RewriteEngine on):

RewriteBase /myapp/

Гайд: http://httpd.apache.org/docs/current/mod/mod_rewrite.html#rewritebase

Уверен на 90% что решит все вопросы )

AMILO likes this

Share this post


Link to post
Share on other sites

@zenn, Привет) Во-втором скрипте .htaccess вообще пустой. 

Создайте и установите это правило(оно запретит выше лежащему перезаписывать роуты). Всего 2 строки - включить rewrite и установить baseurl.

Или в выше лежащем попробуйте заменить:

<Directory /forum>
    RewriteEngine Off
</Directory>
<Directory />
    RewriteEngine On
    blablabla весь прочий шлак
</Directory>

Share this post


Link to post
Share on other sites

Сколько нужно комнатных оптимизаторов чтобы исправить роутинг? Эта тема тому пример.

 

Ровно столько , сколько и клавишных идолоподобных виртуальных героев

 

P.S. По себе людей не судят...

Share this post


Link to post
Share on other sites

@zenn, можете напечатать мне что именно надо добавить в .htaccess второго скрипта?

Сейчас файл абсолютно пустой.

Share this post


Link to post
Share on other sites

@zenn, можете напечатать мне что именно надо добавить в .htaccess второго скрипта?

Сейчас файл абсолютно пустой.

Я так понял что RewriteBase /forum/

Share this post


Link to post
Share on other sites

@zenn, можете напечатать мне что именно надо добавить в .htaccess второго скрипта?

Сейчас файл абсолютно пустой.

    RewriteEngine On
    RewriteBase /forum/

или:

    RewriteEngine Off 

Или попробовать привести основной (выше лежащий) htaccess к виду, как я изложил выше.

Share this post


Link to post
Share on other sites

@zenn, содержимое первого .htaccess

DirectoryIndex index.php
Options -Indexes
Allow from all
<Files "*.htaccess">
order allow,deny
deny from all
</Files>
<Files ~ "php.ini"> 
Order allow,deny 
Deny from All 
</Files>
<Files "*.inc">
order allow,deny
deny from all
</Files>
<Files "*.tpl">
order allow,deny
deny from all
</Files>
<Files ~ "\.(htaccess|htpasswd|inc|dat|ini)$">
Deny from All
</Files>

RemoveHandler .html .htm
AddType application/x-httpd-php .php .htm .html .phtml .inc
AddDefaultCharset utf-8

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php?wtpath=$1&wtquery=%{QUERY_STRING} [L]

ErrorDocument 400 /index.php?section=errordocument&errcode=400
ErrorDocument 401 /index.php?section=errordocument&errcode=401 
ErrorDocument 403 /index.php?section=errordocument&errcode=403 
ErrorDocument 404 /index.php?section=errordocument&errcode=404

php_flag magic_quotes_gpc 0
php_flag magic_quotes_runtime 0  

Содержимое второго - пустой.

 

Если я меняю так как вы говорите - то по адресу site.ru - открывается форум.

Share this post


Link to post
Share on other sites

@zenn, содержимое первого .htaccess

DirectoryIndex index.php
Options -Indexes
Allow from all
<Files "*.htaccess">
order allow,deny
deny from all
</Files>
<Files ~ "php.ini"> 
Order allow,deny 
Deny from All 
</Files>
<Files "*.inc">
order allow,deny
deny from all
</Files>
<Files "*.tpl">
order allow,deny
deny from all
</Files>
<Files ~ "\.(htaccess|htpasswd|inc|dat|ini)$">
Deny from All
</Files>

RemoveHandler .html .htm
AddType application/x-httpd-php .php .htm .html .phtml .inc
AddDefaultCharset utf-8

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php?wtpath=$1&wtquery=%{QUERY_STRING} [L]

ErrorDocument 400 /index.php?section=errordocument&errcode=400
ErrorDocument 401 /index.php?section=errordocument&errcode=401 
ErrorDocument 403 /index.php?section=errordocument&errcode=403 
ErrorDocument 404 /index.php?section=errordocument&errcode=404

php_flag magic_quotes_gpc 0
php_flag magic_quotes_runtime 0  

Содержимое второго - пустой.

 

Если я меняю так как вы говорите - то по адресу site.ru - открывается форум.

Такого быть не может, если вы понимаете что делаете. Такое произойдет только если вы в основной .htaccess запишите то, что предназначалось для форумного ... 

Неужели вы 3 строчки прочесть не можете?

Share this post


Link to post
Share on other sites

@zenn, ну отредактируйте мне первый .htaccess так, как вы считаете правильно.

Share this post


Link to post
Share on other sites

@zenn, ну отредактируйте мне первый .htaccess так, как вы считаете правильно.

Может быть вас еще с ложечки покормить, на горшок сводить? 

Самый простой путь, повторю еще раз, открыть в файловом менеджере директорию, куда загружен форум. Создать файл:

.htaccess

В него поместить:

RewriteEngine Off

проверить в браузере - не помогло, попробовать:

    RewriteEngine On
    RewriteBase /forum/

не помогло - заменить главный(в корне сайта, НЕ ФОРУМА) на (не предпочтительный вариант):

DirectoryIndex index.php
Options -Indexes
Allow from all
<Files "*.htaccess">
order allow,deny
deny from all
</Files>
<Files ~ "php.ini"> 
Order allow,deny 
Deny from All 
</Files>
<Files "*.inc">
order allow,deny
deny from all
</Files>
<Files "*.tpl">
order allow,deny
deny from all
</Files>
<Files ~ "\.(htaccess|htpasswd|inc|dat|ini)$">
Deny from All
</Files>
<Directory /forum>
    RewriteEngine off
</Directory>
<Directory />
	RemoveHandler .html .htm
	AddType application/x-httpd-php .php .htm .html .phtml .inc
	AddDefaultCharset utf-8

	RewriteEngine On
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteRule ^(.*)$ index.php?wtpath=$1&wtquery=%{QUERY_STRING} [L]

	ErrorDocument 400 /index.php?section=errordocument&errcode=400
	ErrorDocument 401 /index.php?section=errordocument&errcode=401 
	ErrorDocument 403 /index.php?section=errordocument&errcode=403 
	ErrorDocument 404 /index.php?section=errordocument&errcode=404

	php_flag magic_quotes_gpc 0
	php_flag magic_quotes_runtime 0  
</Directory>
AMILO and Indigo88 like this

Share this post


Link to post
Share on other sites

Сдается мне что последний вариант должен 100% работать. Впервые вижу такую структуру, спасибо

Share this post


Link to post
Share on other sites

@zenn, Отвечаю по порядку.

 

1-й случай, ничего не меняется, циклическая переадресация на: 

The requested URL /forum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/index.phpforum/ was not found on this server.

2-й случай - тоже самое.

 

3-й случай:

500 Server error.

Share this post


Link to post
Share on other sites

Значить добавить DirectoryIndex указатель к первым 2м примерам.

Share this post


Link to post
Share on other sites

RewriteEngine off RemoveHandler .html .htm AddType application/x-httpd-php .php .htm .html .phtml .inc AddDefaultCharset utf-8 RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php?wtpath=$1&wtquery=%{QUERY_STRING} [L] ErrorDocument 400 /index.php?section=errordocument&errcode=400 ErrorDocument 401 /index.php?section=errordocument&errcode=401 ErrorDocument 403 /index.php?section=errordocument&errcode=403 ErrorDocument 404 /index.php?section=errordocument&errcode=404 php_flag magic_quotes_gpc 0 php_flag magic_quotes_runtime 0

Ошибка 500. Короче, забиваю.

Share this post


Link to post
Share on other sites

@saskozp, Не работает. Пишет: На этой странице обнаружена циклическая переадресация

Share this post


Link to post
Share on other sites

В общем я не знаю что у вас с веб-сервером, провел тестирование на локалке - все хорошо с любым из моих примеров.

Держите тестовый архив: https://yadi.sk/d/bi-kP0NnbxZra

AMILO likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.