Sign in to follow this  
Followers 0
ComTell

Кто разбирается в Linux

12 posts in this topic

Не могу установить Apache, PHP и тд!

При установке выдает какую-то ошибку

root@38332:~# apt-get install apache2 php5 imagemagick libapache2-mod-php5 php5-gd php5-imagick php5-mcrypt
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apache2 : Depends: apache2-bin (= 2.4.10-3) but it is not going to be installed
           Depends: apache2-data (= 2.4.10-3) but it is not going to be installed
           Recommends: ssl-cert but it is not going to be installed
 imagemagick : Depends: imagemagick-6.q16 (= 8:6.8.9.6-4)
 libapache2-mod-php5 : Depends: libonig2 (>= 5.9.5) but it is not going to be installed
                       Depends: libqdbm14 (>= 1.8.74) but it is not going to be installed
                       Depends: libxml2 (>= 2.9.0) but 2.7.8.dfsg-5.1ubuntu4.9 is to be installed
                       Depends: apache2-api-20120211
                       Depends: php5-common (= 5.6.0+dfsg-1+b1) but 5.3.10-1ubuntu3.14 is to be installed
                       Depends: php5-cli but it is not going to be installed
 libc6 : Breaks: locales (< 2.19)
 php5 : Depends: php5-common (>= 5.6.0+dfsg-1~) but 5.3.10-1ubuntu3.14 is to be installed
 php5-gd : Depends: libgd3 (>= 2.1.0) but it is not going to be installed
           Depends: libjpeg62 (>= 1:1.3.1) but it is not going to be installed
           Depends: libvpx1 (>= 1.0.0) but it is not going to be installed
           Depends: phpapi-20131226
           Depends: php5-common (= 5.6.0+dfsg-1+b1) but 5.3.10-1ubuntu3.14 is to be installed
 php5-imagick : Depends: libgomp1 (>= 4.2.1) but it is not going to be installed
                Depends: libmagickcore-6.q16-2 (>= 8:6.8.8.2) but it is not going to be installed
                Depends: libmagickwand-6.q16-2 (>= 8:6.8.8.2) but it is not going to be installed
                Depends: phpapi-20131226
                Recommends: ghostscript
 php5-mcrypt : Depends: libltdl7 (>= 2.4.2) but it is not going to be installed
               Depends: libmcrypt4 but it is not going to be installed
               Depends: phpapi-20131226
               Depends: php5-common (= 5.6.0+dfsg-1+b1) but 5.3.10-1ubuntu3.14 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Share this post


Link to post
Share on other sites

@edward-burya, Пробовал, вот что выдает

root@38332:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  locales
The following packages will be upgraded:
  locales
1 upgraded, 0 newly installed, 0 to remove and 361 not upgraded.
1 not fully installed or removed.
Need to get 0 B/3,957 kB of archives.
After this operation, 7,245 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  locales
Install these packages without verification [y/N]? y
Preconfiguring packages ...
(Reading database ... 48663 files and directories currently installed.)
Preparing to replace locales 2.13+git20120306-3 (using .../locales_2.19-11_all.deb) ...
Unpacking replacement locales ...
dpkg: error processing /var/cache/apt/archives/locales_2.19-11_all.deb (--unpack):
 trying to overwrite '/usr/sbin/update-locale', which is also in package libc-bin 2.15-0ubuntu10.7
dpkg-deb (subprocess): subprocess data was killed by signal (Broken pipe)
dpkg-deb: error: subprocess <decompress> returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/locales_2.19-11_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Avantyrist likes this

Share this post


Link to post
Share on other sites

Беда в зависимостях, такое бывает когда подключаешь сторонние репозитории, после чего apt-get можно хоронить. Выпиливайте левые репозитории, удаляйте весь зависимый софт и ставьте снова, если нет желания разгребать зависимости(вручную обкатывать каждое приложение до нужной версии с cmake & install с сорсов - но может получиться так, что 2 разным приложениям с разных репозиториев будут нужны разные версии той или иной библиотеки).

ComTell likes this

Share this post


Link to post
Share on other sites

А почему бы не поставить весту, она вместе с собой поставит и apache и nginx и mysql и phpmyadmin.

Avantyrist likes this

Share this post


Link to post
Share on other sites

ISP ставь и не мучайся. За 14 дней можно все настроить на ура.

 

Веста грузит проц. и сама по себе виснет (не советую).

Share this post


Link to post
Share on other sites

Сейчас попробую переустановить Linux и поставить Весту

Share this post


Link to post
Share on other sites

Сейчас попробую переустановить Linux и поставить Весту

Обзор различных панелей управления хостингом на хабре

Share this post


Link to post
Share on other sites

Переустановил ОСЬ, и поставил Весту. Все работает. Проблема видимо была в установленном VSFTPD

Share this post


Link to post
Share on other sites
Проблема видимо была в установленном VSFTPD

Вообще ни разу не в нем, apt о нем ни слова даже не сказал.

Хорошо, что проблему решили. Правда, переустановка системы - это далеко не *nix way.

Share this post


Link to post
Share on other sites

@lukonin, Я пытался обновить что-то (не помню, голова дымится), так вот он выдал типа причина в VSFTPD

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.