Jump to content
Sign in to follow this  
sairon

Компонент Joomla Jcomments не отправляет комментарии

Recommended Posts

Уважаемые форумчане!
В очередной раз обращаюсь к вам с просьбой подсказать путь решения проблемы. Я знаю, что большая часть сайтов форумчан сделана на двигах WP и DLE, однако надеюсь что найдется тот, кто поможет мне с Joomla. Это небольшое отступление. Суть же темы в следующем:
Перестал работать компонент Jcomments. Не отправляются комментарии. Премодерация комментов стоит, но отправленные комментарии не появляются на одобрение в админке. От имени админа тоже не могу отправить комментарии.
Последнее, что делал с сайтом - устанавливал кеширование и в самой CMS и в .htacess, возможно с этим и намудрил, так как я нуб в этих финтифлюшках. Также включал сжатие файлов для ускорения скорости загрузки сайта, но, полагаю, дело не в этом.
Предполагая некоторые ответы в теме, скажу сразу: Гуглом пользоваться умею, но ответов найти не смог.
Собственно пациент: Sairon.ru
Заранее благодарю за посильную помощь.

Share this post


Link to post
Share on other sites

Нужно отключить кеширование в Joomla и сделать кеширование силами php и nginx (для статики)

Спасибо, отключить-то кеширование в joomla сейчас отключу. А вот с 2-мя другими пунктами я не понимаю, если можете объясните поподробнее. php.ini не нашел и у меня Apache. 

Share this post


Link to post
Share on other sites

Отключил кеширование в Joomla и в .htcasses, очистил старый кеш - но проблема осталась.
А ранее ведь работало все...

Актуально
 

Share this post


Link to post
Share on other sites

Существует какая-то проблема со скриптами. Скорее всего скрипты конфликтуют. Попробуйте поотключать разные плагины.

Можно поставить плагин jQuery Easy   . Он реашет проблемы с конфликтами скриптов.

Share this post


Link to post
Share on other sites

Хотел попробывать опубликовать коментарий зарегистрированным пользователем, но регистрация не возможна: получено сообщение "ааЕаВаЕбаНбаЙ аПаАбаАаМаЕбб", собственно такое же сообщение и при авторизации.

Share this post


Link to post
Share on other sites

Хотел попробывать опубликовать коментарий зарегистрированным пользователем, но регистрация не возможна: получено сообщение "ааЕаВаЕбаНбаЙ аПаАбаАаМаЕбб", собственно такое же сообщение и при авторизации.

попробуйте еще раз пожалуйста

Share this post


Link to post
Share on other sites

Хотел попробывать опубликовать коментарий зарегистрированным пользователем, но регистрация не возможна: получено сообщение "ааЕаВаЕбаНбаЙ аПаАбаАаМаЕбб", собственно такое же сообщение и при авторизации.

можете не пробовать, вижу не работает  :lol:

Share this post


Link to post
Share on other sites

При регистрации выдает ошибку: неверный параметр.

Данная проблема решалась в этой теме joomlaforum_ru/index.php?topic=260406.0

Чтобы ошибки на русском писались добавляем в .htaccess строчку AddDefaultCharset UTF-8

Share this post


Link to post
Share on other sites

Попробуйте отключить плагин форму vk

Не думаю, что это выход. Ранее все нормально вместе работало.

Share this post


Link to post
Share on other sites

При регистрации выдает ошибку: неверный параметр.

Данная проблема решалась в этой теме joomlaforum_ru/index.php?topic=260406.0

Чтобы ошибки на русском писались добавляем в .htaccess строчку AddDefaultCharset UTF-8

Спасибо большое, язык поправил, дома буду тему тоже почитаю. А по сабжу темы моей есть предположения?

Share this post


Link to post
Share on other sites

При регистрации выдает ошибку: неверный параметр.

Данная проблема решалась в этой теме joomlaforum_ru/index.php?topic=260406.0

Чтобы ошибки на русском писались добавляем в .htaccess строчку AddDefaultCharset UTF-8

Вторую ошибку также поправил, еще раз спасибо! Что не поленились, нашли и прислали УРЛ темы :)  ;)

Share this post


Link to post
Share on other sites

В этой теме скорее всего и есть решение ваших проблем. Вы попробуйте файл htaccess поменять на изночальный. Можете попробовать полностью выключить кеш в настройках, не забудьте его почистить. Отключите все плагины кеширования.

Share this post


Link to post
Share on other sites

При регистрации выдает ошибку: неверный параметр.

Данная проблема решалась в этой теме joomlaforum_ru/index.php?topic=260406.0

Чтобы ошибки на русском писались добавляем в .htaccess строчку AddDefaultCharset UTF-8

Ну и третий раз спасибо! Комменты тоже заработали. Дело было в 301 редирете прописанном в .htcasses. Решил я как-то редиректить страницы с sairon.ru/1/ на sairon.ru/1 (без слеша в конце). Это все и сгубило. И регистрацию, и комменты. 

 

Всем отписавшимся в теме и написавшим мне в ЛС огромное спасибо, и удачи во всех начинаниях! 

 

Админам: тему можно закрывать, выход найден.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...