Jump to content
Воланд

Вордпресс и SSL сертификат

Recommended Posts

Приветствую Уважаемые коллеги!

 

Все таки решил я последовать совету Яндекса и Гугла о том, что лучше перейти на SSL (https) и заказал себе сертификат.

Сказано - сделано...хостинг помог его поставить, но тут столкнулся с проблемой.

 

Заключается она в том, что, если я набираю сайт через http , то все нормально, если через https, то отображение сайта кривое. Насколько я понимаю не подгружаются какие то стили, скрипты или модули (например слайдер).

 

Так вот вопрос - кто нибудь решал уже данный баг?

 

Я пробовал в админке Вордпресс менять адрес сайта на https, но добился только циклической переадресации при входе в Админку. Пробовал ставить специальный плагин - то же видимого эффекта - 0

Share this post


Link to post
Share on other sites

Кривое отображение во всех браузерах?

В config.php (в корне) делали замену?

Найти:

define('HTTP_SERVER', 'http://ваш сайт/');

Заменить на:

define('HTTP_SERVER', 'https://ваш сайт/');

Найти:

define('HTTPS_SERVER', 'http://ваш сайт/');

Заменить на:

define('HTTPS_SERVER', 'https://ваш сайт/');

Share this post


Link to post
Share on other sites

Кривое отображение во всех браузерах?

В config.php (в корне) делали замену?

Найти:

define('HTTP_SERVER', 'http://ваш сайт/');
Заменить на:

define('HTTP_SERVER', 'https://ваш сайт/');
Найти:

define('HTTPS_SERVER', 'http://ваш сайт/');
Заменить на:

define('HTTPS_SERVER', 'https://ваш сайт/');

 

Да, во всех. У меня там установлена платная тема, которая кучу модулей требует, в том числе слайдер, он как раз не отображается. Может быть при установке этих модулей где то прописалось http?

 

По крайней мере я других причин не вижу...

 

Насчет замены, это то же самое, что я поменял в Админке..как я уже говорил - результат нулевой (

Share this post


Link to post
Share on other sites

А Вы картинки в слайдер добавляли как абсолютные или относительные ссылки?

Там не только слайдер..там css не подгружается нормально

 

В общем, надеюсь не посчитаете за рекламу, что бы было наглядней:

 

https:// discoverycenter.ru

 

если ввести с http то отображается как надо

Share this post


Link to post
Share on other sites

Браузер блокирует некоторые стили и скрипты, из-за того что они подгружаются по HTTP, а сам сайт работает по HTTPS. Вот такое сообщение в консоли браузера:

Mixed Content: The page at 'https://discoverycenter.ru/' was loaded over HTTPS, but requested an insecure script 'http://discoverycenter.ru/wp-content/themes/tjoy/js/bootstrap.min.js?ver=3.1'. This request has been blocked; the content must be served over HTTPS.

Скорее всего нужно поправить шаблон.

Share this post


Link to post
Share on other sites

Наверное уже починили. У меня работает что с https, что с http

Никто ничего не чинил...а какой у Вас браузер, если не секрет?

Share this post


Link to post
Share on other sites

Приветствую...ssl не устанавливал, но увидел не большую ошибочку, забыли изменить в обработчике поиска протокол на https... а то после ввода данных в форму редиректит на http

<form method="get" class="header-search-form visible-lg visible-md" action="http:// discoverycenter.ru">

Share this post


Link to post
Share on other sites

Все верно, некоторые скрипты подгружаются через Http а не Https, поэтому все и криво. Либо ручками, либо попробуйте вставить в htaccess вот что:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

Share this post


Link to post
Share on other sites

Все верно, некоторые скрипты подгружаются через Http а не Https, поэтому все и криво. Либо ручками, либо попробуйте вставить в htaccess вот что:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

 

Циклическая выскакивает. Здесь надо куда то прописывать урл? Что то к вечеру уже голова не варит...

Share this post


Link to post
Share on other sites

Циклическая выскакивает. Здесь надо куда то прописывать урл? Что то к вечеру уже голова не варит...

 

Нет, прямо так вставьте в htaccess. 

Share this post


Link to post
Share on other sites

Нет, прямо так вставьте в htaccess.

Прямо так - циклическая переадресация...

 

Приветствую...ssl не устанавливал, но увидел не большую ошибочку, забыли изменить в обработчике поиска протокол на https... а то после ввода данных в форму редиректит на http

<form method="get" class="header-search-form visible-lg visible-md" action="http:// discoverycenter.ru">

да тут хотя бы с отображением разобраться  ;)

 

В общем, как правильно сказали люди выше, мне кажется, что просто блокируются некоторые стили и скрипты..вопрос в том, как это поправить не переставляя Вордпресс

Share this post


Link to post
Share on other sites

Если не ошибаюсь, тебе нужно в редактор шаблона и все там корректировать!

Share this post


Link to post
Share on other sites

Тогда ручками, скорее всего. Для помощи такой плагин нарыл: https://wordpress.org/plugins/https-mixed-content-detector/, он ищет эти самые скрипты и выводит их в логе. Так будет быстрее. Ну и терпения вам))

Share this post


Link to post
Share on other sites

То же самое....

Не тупите, посмотрите HTML код на сайте, дело в шаблоне!!! И соответственно, его и нужно править..

Share this post


Link to post
Share on other sites

Никто ничего не чинил...а какой у Вас браузер, если не секрет?

Смотрел в Опера 12 с копейками. Все нормально отображается в обоих режимах

Share this post


Link to post
Share on other sites

Тогда ручками, скорее всего. Для помощи такой плагин нарыл: https://wordpress.org/plugins/https-mixed-content-detector/, он ищет эти самые скрипты и выводит их в логе. Так будет быстрее. Ну и терпения вам))

 

Наверное хороший плагин, жаль, не работает..

 

 

Не тупите, посмотрите HTML код на сайте, дело в шаблоне!!! И соответственно, его и нужно править..

 

Советую Вам повежливей разговаривать...

 

 

Что там в конфигурации nginx? Секция http

 

Настраивала сертификат поддержка хостинга...думаю учли это..не первый 10ток раз ставят...

 

 

Смотрел в Опера 12 с копейками. Все нормально отображается в обоих режимах

 

Самое интересное, что у кого то и в Хроме отображается нормально...

 

В общем. если сможете платно глянуть и настроить - буду денежно благодарен....

Share this post


Link to post
Share on other sites

В файл wp-config.php вставить следующее.

define('FORCE_SSL_ADMIN', true);

Потом в Настройки->Общее

 

Поменять!

 

Адрес WordPress (URL) поставить https адрес 
 

Адрес сайта (URL) поставить https адрес 

 

Пробуйте.

Share this post


Link to post
Share on other sites

Сейчас с смартфона сижу. Проверил. И что? Также все прекрасно работает. На счёт глянуть, то завтра с обеда, если проблема к этому времени не будет решена.

Share this post


Link to post
Share on other sites

В файл wp-config.php вставить следующее.

define('FORCE_SSL_ADMIN', true);

Потом в Настройки->Общее

 

Поменять!

 

Адрес WordPress (URL) поставить https адрес 
 

Адрес сайта (URL) поставить https адрес 

 

Пробуйте.

 

Пробовал. После правки конфига происходит циклическая переадресация, и в админку войти невозможно, хотя главная открывается

Share this post


Link to post
Share on other sites

сделайте 301 редирект через файл htaccess, что есть правильно

второе, может у вас в шаблоне прописаны прямые ссылки на стили?

и, попробуйте переустановить шаблон

 

все стили и скрипты грузятся с http:// , однозначно, или прописаны пути в шаблоне, или может быть у вас работает кеширование

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...