Jump to content

Проблемы с дле 9.7 и instantcms


Recommended Posts

Привет всем. Возникла проблема с сайтом. Пытался поставить поверх дле 9.7 instantcms сразу через сайт. Не получилось. Удалил все файлы инстанта, правда пришлось перезаписать чистый index.php для сайта. Однако вместо русского языка появилось нечитаемые символы - будто не та кодировка (на сайте и в админке) . Однако в настройках системы стоит все также windows-1251.

 

Кто может посоветовать что-то путное, чтобы вернуть русский язык на сайт (английский на сайте отображается)? Спасибо за помощь.

 

И заодно, кто знает как правильно поставить таки Instantcms поверх существующего движка?

Link to post
Share on other sites

.htaccess в студию. А ссылку на сайт в ЛС.

Думаю не в этом проблема - я htaccess на оригинальный заменил из пакета дле. Там все норм.

А вот в phpmyadmin вечно выскакивает кодировка utf-8 в "Сопоставление кодировки соединения с MySQL"  и как ее заменить на windows-1251 хз.

Link to post
Share on other sites

+ PS/ инстант на UTF8, вам с самого начала, нужно было DLE с этой кодировкой ставить.

В смысле с utf8? Так она ж не работает по-русски. Потому 1251 стояла, а теперь нет

Link to post
Share on other sites

В смысле с utf8? Так она ж не работает по-русски. Потому 1251 стояла, а теперь нет

Нет, UTF8 универсальная и работает, и с рус. языком.

 

Файлы /engine/dbconfig.php, config.php - там может кодировка другая стоят, у файла index.php кодировку посмотрите - должна (ANSI) win1251 - стоят.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...