secher90

Не добавляется картинка к пункту меню через административную панель Joomla

7 сообщений в этой теме

Всем привет. Не добавляется картинка к пункту main меню через административную панель Joomla (версия 3.6.5.). Каким образом пытался добавить?: main menu - "моё мёню"- параметры ссылки - выбрать картинку. При нажатии на кнопку "Выбрать" кнопка не активна и не реагирует "на раздражители"))  )(скриншот)

599de4c157582_.thumb.png.7e34a56eca1745f0fd9b7615c2c4e3c5.png

Самое интересное в том, что при создании первого пункта в этом меню я легко добавил картинку таким образом, а спустя несколько дней данная функция перестала работать и даже к первому пункту меню не получается изменить или даже удалить иконку.
Версия Joomla 3.6.5
Использую hikashop, Cherry Picker for HikaShop
Пробовал поочерёдно отключать все модули и расширения, но проблема таким образом не решается. Сталкивался ли кто-нибудь с этим? Есть ли идеи? Всем спасибо.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Идеи есть всегда,смените Ваш обычный браузер на чистый без куков и прочего мусора связанного с вашей админкой и попробуйте.

Отпишите результат...

У меня было такое правда не картинкой меню,но тоже скрипт повис намертво и не реагировал с привычного браузера, как понял в чем суть браузер обычный подчистил и все заработало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо Serjin за идею. Почистил, попробовал несколько других браузеров и с другого "чистого" компьютера, но всё также скрипт не реагирует. Придумал решение через php + сss прикрепить иконки к пунктам меню, но они криво становятся на мобильной версии, придётся на гаджетах вообще выключить отображение иконок. Но это "костыль", а не решение. Хотелось бы стандартным способом заливать, тогда корректно отображается на разных устройствах.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На вордпрессе бывает что не загружаются картинки из отсутствия прав на папку, может стоить прав побольше дать, а возможно что сама цмс не создала паку для картинок. Надо посмотреть и создать ее руками

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, secher90 сказал:

Спасибо Serjin за идею. Почистил, попробовал несколько других браузеров и с другого "чистого" компьютера, но всё также скрипт не реагирует. Придумал решение через php + сss прикрепить иконки к пунктам меню, но они криво становятся на мобильной версии, придётся на гаджетах вообще выключить отображение иконок. Но это "костыль", а не решение. Хотелось бы стандартным способом заливать, тогда корректно отображается на разных устройствах.

Если хотите родного ищите где у Вас конфликт скрипта,в чистой джумле такого точно нету,там все пашет.(уверен если поставите тот-же пакет с нуля все будет работать)

Это пришло со временем что-то отпало или переписалось плагином/модулем.

Фаербаг Вам в помощь им отловите конфликт скрипта, ну или накатайте поверх сайта чистые файлы джумлы, возможно поможет. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, seo-net сказал:

На вордпрессе бывает что не загружаются картинки из отсутствия прав на папку, может стоить прав побольше дать, а возможно что сама цмс не создала паку для картинок. Надо посмотреть и создать ее руками

Спасибо. Но папки все на месте по дефолту,  с правами всё в порядке. Причина не в этом, ведь я прикрепил первую иконку к пункту меню, а вот спустя пару дней данная опция не активна. Тут реально конфликт скриптов, но кто с чём конфликтует понять пока не удаётся. 
 

50 минут назад, serjin сказал:

Если хотите родного ищите где у Вас конфликт скрипта,в чистой джумле такого точно нету,там все пашет.(уверен если поставите тот-же пакет с нуля все будет работать)

Это пришло со временем что-то отпало или переписалось плагином/модулем.

Фаербаг Вам в помощь им отловите конфликт скрипта, ну или накатайте поверх сайта чистые файлы джумлы, возможно поможет. 

Спасибо. Да, в чистом шаблоне (yootheme использую с новым билдером) таких проблем не будет, я сам уверен. Но переустанавливать с нуля я точно не буду, так как настроил уже корзину, заказ товара, все фильтры на товары, категории и т.д. Буду через сss добавлять картинки к меню, а в мобильной версии отключу иконки. 


Всем спасибо. Если найду причину, то обязательно отпишу в теме.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

- Достаточно часто после обновлений cms админка вообще "не кликабельна" (лечится F5).

- Мелкие "заскоки" периодически случаются, обычно "проходят" при обновлении.

- Возможно, стоит почистить кэш на сайте (весь, устаревший, обновлений). Хотя, наверное, это сделано :)  Банально, но иногда забывается.

- Некоторые скрипты (в админпанели) не работают на джумле при включенном "ускорении" js на cloudflare (если подключено, естественно), на время работы с админ-панелью - отключаю "облако" и отдельно - снимаю все флажки во вкладке speed.

- возможно, имеет значение версия php. Впрочем, если кнопка изначально работала, то маловероятно.

- версия: поспрошать на джумловском форуме поддержки.

Так, в порядке "идей". Вроде что-то было похожее... не вспомню, "само прошло", вроде как. Обновляться-то все равно нужно, сегодня ужжо - v. 3.7.5  Магазин, наверное, не адаптирован под "новьё"? (в принципе, как всегда с джумлой, помогут "танцы с бубном" :) )

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу