Jump to content
files

Сайт не загружается целиком

Recommended Posts

Есть проблема на внутренних страницах сайта в виде недогрузки контента.

Главная сайта загружается нормально, а вот все остальные (кроме главной) страницы до конца не прогружаются (см. скрин).

RSNH3SQdq0.jpg

При каждом новом обновлении +/- несколько байт к странице, что не может быть связано с кодом сайта. Проблема в конфигурации сервера, но что подкрутить - не ясно.

Конфигурация сервера:

Apache    2.4.6-67.el7.centos.2
MySQL    5.5.56-2.el7
PHP    5.2.17

Кто сталкивался с подобным? Кто что может посоветовать?

Share this post


Link to post
Share on other sites

Если ошибки ранее не было и это VPS попробуйте перезагрузится. 

Я не спец в конф. сервера, но вот пару предположений. Может есть ограничения на кол. подключений за один раз ? (обычно есть, 10-20 коннектов к серверу и ожидание пока не отдает все и потом новые коннекты, может в процессе прерывает). 

Может тупо оперативки не хватает или места на жестком диске.

Если главная по объему похожая на внутренние, все таки стоит проверить код сайта, точнее буферизацию Ob_start и т.д. 

Попробуйте через прокси, может в настройках безопасности ваш ИП в временный лимит попал (если стоит какой-то плагин от ддос защиты, то такое возможно)

Share this post


Link to post
Share on other sites

Сайт перенесли с другого хостинга. Места, памяти и прочих лимитов - с лихвой. Перезагружались, обновлялись - без толку.

Share this post


Link to post
Share on other sites
1 минуту назад, petroff сказал:

Если речь о сайте bau-market, то у меня все нормально грузится. Ошибок, как на скрине нет

Все верно. Но вы смотрите рабочий сайт на другом хостинге, откуда мы его переносим.

php.ini

engine = On
short_open_tag = On
asp_tags = Off
precision = 14
output_buffering = 4096
zlib.output_compression = Off
implicit_flush = Off
unserialize_callback_func =
serialize_precision = 17
disable_functions =
disable_classes =
zend.enable_gc = On
expose_php = On
max_execution_time = 30
max_input_time = 60
memory_limit = 128M
error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT
display_errors = Off
display_startup_errors = Off
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
html_errors = On
variables_order = "GPCS"
request_order = "GP"
register_argc_argv = Off
auto_globals_jit = On
post_max_size = 64M
auto_prepend_file =
auto_append_file =
default_mimetype = "text/html"
doc_root =
user_dir =
enable_dl = Off
file_uploads = On
upload_max_filesize = 35M
max_file_uploads = 20
allow_url_fopen = On
allow_url_include = Off
default_socket_timeout = 60
[CLI Server]
cli_server.color = On
[Date]
date.timezone = Europe/Moscow
[filter]
[iconv]
[intl]
[sqlite]
[sqlite3]
[Pcre]
[Pdo]
[Pdo_mysql]
pdo_mysql.cache_size = 2000
pdo_mysql.default_socket=
[Phar]
[mail function]
SMTP = localhost
smtp_port = 25
sendmail_path = /usr/sbin/sendmail -t -i
mail.add_x_header = On
[SQL]
sql.safe_mode = Off
[ODBC]
odbc.allow_persistent = On
odbc.check_persistent = On
odbc.max_persistent = -1
odbc.max_links = -1
odbc.defaultlrl = 4096
odbc.defaultbinmode = 1
[Interbase]
ibase.allow_persistent = 1
ibase.max_persistent = -1
ibase.max_links = -1
ibase.timestampformat = "%Y-%m-%d %H:%M:%S"
ibase.dateformat = "%Y-%m-%d"
ibase.timeformat = "%H:%M:%S"
[MySQL]
mysql.allow_local_infile = On
mysql.allow_persistent = On
mysql.cache_size = 2000
mysql.max_persistent = -1
mysql.max_links = -1
mysql.default_port =
mysql.default_socket =
mysql.default_host =
mysql.default_user =
mysql.default_password =
mysql.connect_timeout = 60
mysql.trace_mode = Off
[MySQLi]
mysqli.max_persistent = -1
mysqli.allow_persistent = On
mysqli.max_links = -1
mysqli.cache_size = 2000
mysqli.default_port = 3306
mysqli.default_socket =
mysqli.default_host =
mysqli.default_user =
mysqli.default_pw =
mysqli.reconnect = Off
[mysqlnd]
mysqlnd.collect_statistics = On
mysqlnd.collect_memory_statistics = Off
[OCI8]
[PostgreSQL]
pgsql.allow_persistent = On
pgsql.auto_reset_persistent = Off
pgsql.max_persistent = -1
pgsql.max_links = -1
pgsql.ignore_notice = 0
pgsql.log_notice = 0
[Sybase-CT]
sybct.allow_persistent = On
sybct.max_persistent = -1
sybct.max_links = -1
sybct.min_server_severity = 10
sybct.min_client_severity = 10
[bcmath]
bcmath.scale = 0
[browscap]
[Session]
session.save_handler = files
session.use_cookies = 1
session.use_only_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.cookie_httponly =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
session.bug_compat_42 = Off
session.bug_compat_warn = Off
session.referer_check =
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
session.hash_function = 0
session.hash_bits_per_character = 5
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
[MSSQL]
mssql.allow_persistent = On
mssql.max_persistent = -1
mssql.max_links = -1
mssql.min_error_severity = 10
mssql.min_message_severity = 10
mssql.compatability_mode = Off
mssql.secure_connection = Off
[Assertion]
[mbstring]
[gd]
[exif]
[Tidy]
tidy.clean_output = Off
[soap]
soap.wsdl_cache_enabled=1
soap.wsdl_cache_dir="/tmp"
soap.wsdl_cache_ttl=86400
soap.wsdl_cache_limit = 5
[sysvshm]
[ldap]
ldap.max_links = -1
[mcrypt]
[dba]

 

Share this post


Link to post
Share on other sites
1 минуту назад, files сказал:

Все верно. Но вы смотрите рабочий сайт на другом хостинге, откуда мы его переносим.

php.ini

И еще логи апача...

Share this post


Link to post
Share on other sites
[Fri Oct 06 19:21:02.749108 2017] [mpm_prefork:notice] [pid 1046] AH00171: Graceful restart requested, doing restart
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 83105.local. Set the 'ServerName' directive globally to suppress this message
[Fri Oct 06 19:21:03.134720 2017] [auth_digest:notice] [pid 1046] AH01757: generating secret for digest authentication ...
[Fri Oct 06 19:21:03.135263 2017] [lbmethod_heartbeat:notice] [pid 1046] AH02282: No slotmem from mod_heartmonitor
[Fri Oct 06 19:21:03.157823 2017] [mpm_prefork:notice] [pid 1046] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips mod_fcgid/2.3.9 PHP/5.4.16 configured -- resuming normal operations
[Fri Oct 06 19:21:03.157852 2017] [core:notice] [pid 1046] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'


::1 - - [06/Oct/2017:20:13:39 +0300] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips mod_fcgid/2.3.9 PHP/5.4.16 (internal dummy connection)"
::1 - - [06/Oct/2017:20:14:07 +0300] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips mod_fcgid/2.3.9 PHP/5.4.16 (internal dummy connection)"
::1 - - [06/Oct/2017:20:14:24 +0300] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips mod_fcgid/2.3.9 PHP/5.4.16 (internal dummy connection)"

 

Share this post


Link to post
Share on other sites
43 минуты назад, files сказал:

PHP    5.2.17

 

16 минут назад, files сказал:

[Fri Oct 06 19:21:03.157823 2017] [mpm_prefork:notice] [pid 1046] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips mod_fcgid/2.3.9 PHP/5.4.16 configured -- resuming normal operations

 

Очень интересно, что еще не совпадает с заявленным...

Скорее всего не правильно настроили сервер или модули веб-сервера, найдите нормальный мануал и настройте с нуля.

P.S. Как вариант можно попробовать снести htaccess и посмотреть что будет...

Share this post


Link to post
Share on other sites
Цитата

Очень интересно, что еще не совпадает с заявленным...

P.S. Как вариант можно попробовать снести htaccess и посмотреть что будет...

На сервере стоит 5.4 . Наш сайт использует 5.2

При отключении htaccess - главная работает как и работала, внутренние целиком нет.

Цитата

output_buffering = 4096 

увеличте в 2 раза и проверьте

Не помогло.

Кто готов посмотреть по SSH? Вознаграждение полагается.

 

P.S. Может это прояснит ситуацию? Сайт закодирован в Zend, поэтому стоит именно 5.2 PHP (в которой он был закодирован изначально). Но скорее всего проблема в Apache, ЧПУ... Не просил бы помощи, если бы знал настроить сервер под него.

Share this post


Link to post
Share on other sites
9 минут назад, files сказал:

На сервере стоит 5.4 . Наш сайт использует 5.2

При отключении htaccess - главная работает как и работала, внутренние целиком нет.

Не помогло.

Кто готов посмотреть по SSH? Вознаграждение полагается.

Сорри может за глупый вопрос, а вывод ошибок включен?

Share this post


Link to post
Share on other sites
Цитата

Сорри может за глупый вопрос, а вывод ошибок включен?

Включен в файл. И он пустой. Создаем ошибки сами, записываются (для перепроверки). 

 

Share this post


Link to post
Share on other sites
1 минуту назад, files сказал:

Может это прояснит ситуацию? Сайт закодирован в Zend, поэтому стоит именно 5.2 PHP (в которой он был закодирован изначально). Но скорее всего проблема в Apache, ЧПУ... Не просил бы помощи, если бы знал настроить сервер под него.

Не соответствие версий имеет место быть, но сайт работает (частично) все таки скорее всего проблема именно в коде.

Запись в файл сразу? Может до нужного участка выключает. Тяжёлые js, css файлы корректно выводить? Попробуйте копию хтмл страницы сохранить с старого сайта, как хтмл файл загрузите на сервер и откройте в браузере

Share this post


Link to post
Share on other sites
Цитата

Запись в файл сразу? Может до нужного участка выключает. Тяжёлые js, css файлы корректно выводить? Попробуйте копию хтмл страницы сохранить с старого сайта, как хтмл файл загрузите на сервер и откройте в браузере

Пробовали создавать html - загружается мгновенно. Как и главная страница - загружается мгновенно, без косяков и т.д. На внутренних страницах везде обрыв кода в пределах 80-90 Кб. Всегда по разному.

Share this post


Link to post
Share on other sites
32 минуты назад, files сказал:

На сервере стоит 5.4 . Наш сайт использует 5.2

 

32 минуты назад, files сказал:

P.S. Может это прояснит ситуацию? Сайт закодирован в Zend, поэтому стоит именно 5.2 PHP (в которой он был закодирован изначально). Но скорее всего проблема в Apache, ЧПУ... Не просил бы помощи, если бы знал настроить сервер под него.

У Вас установлено 2 версии PHP ?

Share this post


Link to post
Share on other sites
16 минут назад, files сказал:

Пробовали создавать html - загружается мгновенно. Как и главная страница - загружается мгновенно, без косяков и т.д. На внутренних страницах везде обрыв кода в пределах 80-90 Кб. Всегда по разному.

Проблема скорее всего в коде сайта, а если он закодирован, это усложнит поиск причины..

 

Цитата

У Вас установлено 2 версии PHP ?

Думаю имелось ввиду, что сайт создавался под 5.2 и закодировн в зенд для 5.2, а сейчас перенесли на новую версию 5.4.

Кстати, есть ли возможность откатить версию на 5.2 и проверить?

Share this post


Link to post
Share on other sites
2 минуты назад, kkey80 сказал:

Проблема скорее всего в коде сайта, а если он закодирован, это усложнит поиск причины..

 

Думаю имелось ввиду, что сайт создавался под 5.2 и закодировн в зенд для 5.2, а сейчас перенесли на новую версию 5.4.

Кстати, есть ли возможность откатить версию на 5.2 и проверить?

Может хватит набивать посты если Вы в этом полный ноль !?

Такую ересь городите, что волосы дыбом становятся...

Share this post


Link to post
Share on other sites
Цитата

У Вас установлено 2 версии PHP ?

Да. 5.2 и 5.4

Цитата

Проблема скорее всего в коде сайта, а если он закодирован, это усложнит поиск причины..

Главная ведь работает.

Share this post


Link to post
Share on other sites
1 минуту назад, files сказал:

Да. 5.2 и 5.4

Скидывайте в ЛС доступ SSH, посмотрю что там за траблы...

Share this post


Link to post
Share on other sites
2 минуты назад, qpPeW сказал:

Может хватит набивать посты если Вы в этом полный ноль !?

Такую ересь городите, что волосы дыбом становятся...

Может хватит беспочвенно обвинять ? В самом первом посте я указал, что не сильно знаю тему, но это не значит, что не могу поделится с ТС своим мнением. И  поверьте, в настройке сервера может я не сильно знаком, но вот в программирование у меня многолетний опыт и стаж, поэтому кое чем все таки помочь могу ТС, ведь сам не раз сталкивался с подобного рода проблемами.

Share this post


Link to post
Share on other sites
Только что, qpPeW сказал:

Скидывайте в ЛС доступ SSH, посмотрю что там за траблы...

Сайт закодирован в 5.2 и запустится только в 5.2, для чего и подключили 5.2

Скидываю.

 

Share this post


Link to post
Share on other sites
4 минуты назад, files сказал:

Да. 5.2 и 5.4

Главная ведь работает.

Для внутренних возможно подключаются файлы, в которых может возникать ошибка. Но если у вас установлены и запущены две версии пхп, то скорее всего проблема именно в этой области

Share this post


Link to post
Share on other sites
Цитата

Для внутренних возможно подключаются файлы, в которых может возникать ошибка. Но если у вас установлены и запущены две версии пхп, то скорее всего проблема именно в этой области

Обрыв происходит каждый раз в разных частях одного и того же кода (я на этом акцентировал)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...