Jump to content

Хелп, поломалась админка Wordpress


Recommended Posts

Помогите кто чем может.

Сломалась админка, не адекватное поведение, пока заметил

в редакторе не могу переключатся между режимом "визуально" и html

Не работают выпадающие подменю в боковом меню самой админки, там где записи, медиа, страницы и так далее.

Пару дней назад ещё всё работало, переустанавливал все файлы сайта из месячного бепапа, тоже самое.

 

Link to post
Share on other sites

нашёл решение,

в файл wp-config.php вставил код

define ( 'CONCATENATE_SCRIPTS', false );

define ( 'CONCATENATE_SCRIPTS', false );

но вопрос открыт, почему это произошло, почему не помог откат файлов той датой, когда всё работало, и что это вообще было?

Link to post
Share on other sites
3 минуты назад, vituson сказал:

Если файлы не влияют, надо бекап базы перезалить. Чудес не бывает.

за месяц столько уже залито, это ппц же

глюк или взломали?

Link to post
Share on other sites
8 часов назад, saskozp сказал:

нашёл решение,

в файл wp-config.php вставил код

define ( 'CONCATENATE_SCRIPTS', false );


define ( 'CONCATENATE_SCRIPTS', false );

но вопрос открыт, почему это произошло, почему не помог откат файлов той датой, когда всё работало, и что это вообще было?

Куда именно в конфиге вставляли данный код?

У меня на одном сайте такая же проблема.

P.S. по гуглил код вставил,   толку ноль.

Link to post
Share on other sites
2 часа назад, Beauty сказал:

wordpress уже не торт https://xakep.ru/tag/wordpress/

Торт, просто Вы не умеете его готовить. Не понятно на что ссылка, но если вы про уязвимость для ддос-атак, то это лечится

Правд пока не приходилось испытывать такие трудности на себе

Link to post
Share on other sites
  • VIP
9 часов назад, saskozp сказал:

Помогите кто чем может.

Сломалась админка, не адекватное поведение, пока заметил

в редакторе не могу переключатся между режимом "визуально" и html

Не работают выпадающие подменю в боковом меню самой админки, там где записи, медиа, страницы и так далее.

Пару дней назад ещё всё работало, переустанавливал все файлы сайта из месячного бепапа, тоже самое.

 

У меня такое с редактором, не работали кнопки и переключение но так и не нашел проблему.. Поэтому установил плагин TinyMCE Advanced, функционала даже добавилось.
А вот про остальное не знаю. Возможно, сморожу глупость, но имеет смысл сделать бэкап а потом попробовать откатить только БД? 

Link to post
Share on other sites
16 часов назад, saskozp сказал:

нашёл решение,

в файл wp-config.php вставил код

define ( 'CONCATENATE_SCRIPTS', false );


define ( 'CONCATENATE_SCRIPTS', false );

но вопрос открыт, почему это произошло, почему не помог откат файлов той датой, когда всё работало, и что это вообще было?

вордпресс не знаю.

чисто логично рассуждая: вероятнее константа - отвечает за объединение яваскрипта в один файл, меняя значение - меняются урлы на 1 общий файл или множетво мелких - ну и соответственно при заходе на сайт обновляются.. посмотрите консоль браузера на предмет js ошибок. если есть - то по ним и далее смотреть..

Link to post
Share on other sites
7 часов назад, sda сказал:

чисто логично рассуждая: вероятнее константа - отвечает за объединение яваскрипта в один файл, меняя значение - меняются урлы на 1 общий файл или множетво мелких - ну и соответственно при заходе на сайт обновляются.. посмотрите консоль браузера на предмет js ошибок. если есть - то по ним и далее смотреть..

работает и ладно, не хочется трогать, когда поломается, тогда и буду голову ломать )

Link to post
Share on other sites
В 16.02.2018 в 0:31 PM, sda сказал:

вордпресс не знаю.

чисто логично рассуждая: вероятнее константа - отвечает за объединение яваскрипта в один файл, меняя значение - меняются урлы на 1 общий файл или множетво мелких - ну и соответственно при заходе на сайт обновляются.. посмотрите консоль браузера на предмет js ошибок. если есть - то по ним и далее смотреть..

вы правы. Снова поломалась админка, на этот раз отвалились поля в сео плагине, они просто не отображаются. Посмотрел в консоли, ошибки на скриптах, зашёл через фтп, открыл их, а они битые, куски кода просто в нулях (в смысле null :)). Не представляю что это, но надеюсь ошибки диска, а не вирусы. Сейчас пишу обращение в поддержку хостинга.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...