Sign in to follow this  
Followers 0
OhYeah

Ошибка при загрузке картинки на WP

18 posts in this topic

Всем доброй ночи!

 

У меня проблема с загрузкой картинок на Wordpress.. Все было нормально, загружалось, как обычно. Но в один день начала появляться ошибка.

iISHTI.png

 

Что с этим делать? В интернете искал, ничего не помогло.

 

Share this post


Link to post
Share on other sites

Права на папку uploads выставите 777.

Картинка случаем не больше 2МВ?

OhYeah likes this

Share this post


Link to post
Share on other sites

Права на папку uploads выставите 777.

Картинка случаем не больше 2МВ?

Не помогло :(

Картинки маленькие совсем, разные пробовал.

Спасибо за ответ

Share this post


Link to post
Share on other sites

блин было такое, но вот что я делал не помню, а раз не помню, значит там всё просто решается вопрос...вспомню напишу

Share this post


Link to post
Share on other sites

Попробуйте открыть файл .htaccess в корне папки с темой и добавить в самый конец эти строки

php_value post_max_size 10M
php_value upload_max_filesize 64M
php_value memory_limit 192M
php_value max_execution_time 100

Share this post


Link to post
Share on other sites

Или установите этот плагин WP Original Media Path и пропишите пути в его настройках

Share this post


Link to post
Share on other sites

вспоминай что делал перед этим? обновлял WP, файлы может правил и кодировку не ту поставил, или плагины ставил/удалял

OhYeah likes this

Share this post


Link to post
Share on other sites

 

Попробуйте открыть файл .htaccess в корне папки с темой и добавить в самый конец эти строки

php_value post_max_size 10M
php_value upload_max_filesize 64M
php_value memory_limit 192M
php_value max_execution_time 100

Именно в папку с темой?

Попробовал - не помогло..

 

Плагин тоже..

 

А вот перед ошибкой возможно обновлял плагины. Что стоит делать?

Share this post


Link to post
Share on other sites

@OhYeah,отключай плагины по очереди и смотри,может все начнет работать. Плагины связаны с галереями и загрузкой картинок? 

Share this post


Link to post
Share on other sites

сорри)) в папке сайта, а не темы.

Попробуйте еще посмотреть в какой кодировке файл function.php, должен быть в utf-8 без бум.

Share this post


Link to post
Share on other sites

@OhYeah,на крайняк откат до версии сайта, когда все еще работало. Если на хостинге есть функция резервного копирования и восстановления сайта. 

Share this post


Link to post
Share on other sites

а и самое важное сначала перезайди в админку!!!!! может тупо глюк))

Share this post


Link to post
Share on other sites

Посмотри, может свободная память на хостинге кончилась.

OhYeah likes this

Share this post


Link to post
Share on other sites

Вариантов решения проблемы может быть несколько (как и уже предложенные).

Попробуйте в .htaccess (в корне)

добавить в самый конец:

 

 

 

<IfModule mod_security.c>
<Files async-upload.php>
SecFilterEngine Off
SecFilterScanPOST Off
</Files>
</IfModule>
OhYeah likes this

Share this post


Link to post
Share on other sites

Всем привет!

 

Вы наверное обновляли WordPress, а у Вас на хостинге выставлена старая версия PHP, на которой WordPress корявенько работает. Поэтому, заходите в панель управлениях хостингом и выставляете из выпадающего списка самую последнюю версию PHP.

OhYeah likes this

Share this post


Link to post
Share on other sites

Всем спасибо за ответы!

 

Но так ничего и не помогло. :wacko:

 

Но компьютере остался бэкап сайта, который делал перед переносом (после переноса все нормально работало). Попробую полностью заменить все файлы.

 

Отпишу, если заработает :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.